September 20, 2019
  • 6:30 pm Office 365 – Yksittäisten tai useiden käyttäjätilien luominen | Office 365 Admin Center & PowerShell
  • 10:09 pm Office 365 – Yhdistäminen tenanttiin PowerShellillä
  • 2:15 pm NameCheap – Kaupallisen SSL-sertifikaatin uusiminen
  • 9:48 pm Ubuntu Server 18.04.3 – Tietoturvapäivitysten automatisointi
  • 1:54 am Tuotantopalvelimen päivitys – Ubuntu Server 16.04 -> 18.04

Alkutoimenpiteet:

  • käytä Moodlesta löytyvää harjoitustehtävän Packet tracer pohjaa ja luo sen avulla harjoitustehtävän kuvan mukainen ympäristö Packet Tracerillä
  • Määrittele kytkimiin VLAN:it ja trunkit kuvan ja osoitetaulukon (Taulukko2) mukaisesti, voit valita eri yhteyksiin käytettävät kytkimien portit itse
  • Käytä PC:ssä osoitetaulukon (Taulukko3) mukaisia kiinteitä IP osoitteita
  • Ota sarjayhteys käyttöön reitittimien välillä sarjakaapelilla. Huomaa että harjoitustehtävän pohjassa olevassa reitittimessä on jo sarjaliitännän mahdollistava kortti valmiiksi asennettuna, eli sinun tulee vain lisätä sarjakaapelit reitittimien välille.
  • Määrittele reitittimen eri rajapintojen IP osoitteet osoitetaulukon (Taulukko1) mukaisesti
  • Määrittele kytkimille ylläpito IP osoitteet (ja VLAN:it) osoitetaulukon (Taulukko2) mukaisesti
  • Testaa että yhteydet PC:ten ja reitittimen (default gateway osoite) välillä toimivat (ping PC:ltä reitittimelle menee läpi)
  • Määrittele kaikille kytkimille ja reitittimille tarpeelliset salasanat ja käytä tuona salasanana aina sanaa ”cisco”

topology1
topology2

Taulukko 1: Reitittimien osoitetaulukko

ip1

Taulukko 2: Kytkimien ylläpito-osoitetaulukko

ip2

Taulukko 3: PC:ten osoitetaulukko

ip3
Heti alkuun, tuli minun luoda ohjekuvien mukainen verkkotopologia Packet Tracerissa.

Nimet ja salasanat laitteille:

Kaikki reitittimet ja kytkimet tulee suojata salasanalla. Tässä harjoituksessa salasana oli kaikilla laitteilla käytännöllisyys syistä “cisco”. On varmaan itsestäänselvää, ettei näin koskaan toimittaisi oikeassa elemässä.

SW1> enable
SW1# configure terminal
SW1(config)# hostname SW1
SW1(config)# enable secret cisco

Ylläolevan esimerkin mukaisesti sama operaation kaikille verkkolaitteille.

Verkkokaapelit kuntoon:

Reitittimien R1, R2 ja R3 välille tarvitaan serialyhteys. Verkkokortit ovat jo asennettuna, joten tarvitsee ainoastaan laittaa kaapelit reitittimien serial-porttien välille:
PT1
featuredPT2
Huomaa, että vaikka ylläolevassa kuvassa interfacet näyttävät vihreää, ne eivät ole oikeasti vielä no shutdown tilassa tässä vaiheessa. No shutdown komento syötetään myöhemmin samalla, kun serial-porteille annetaan IP-osoitteet.
Kytkinten SW1, SW2 ja SW3 välille tarvittiin Copper Cross-over -kaapeli. Näkyy ylemmässä kuvassa mustana katkoviivana. Lisäksi verkkojen tietokoneiden ja kytkinten välille tarvittiin Copper Straight-Through -kaapeli. Sama kaapeli tulee myös reitittimien ja kytkinten välille. Loppu kokonaisuus tulisi näyttää tältä, tosin edelleenkään reitittimien interfacet eivät ole kuvasta huolimatta vielä toiminnassa:
featuredPT

IP-osoitetiedot eri verkkolaitteille:

Verkon päätelaitteet

Tietokoneiden IP-osoitetietojen määrittäminen onnistui klikkaamalla laitetta, jonka jälkeen navigoidaan “Desktop“. Ip Configuration kohtaan laitetaan täppä kohtaan “Static” ja annetaan IPv4-osoite, verkkomaski ja default-gateway ohjetaulukon 3 mukaisesti. Esimerkiksi PC11:n osoitetietojen konfigurointi:
PT2
Sama operaation taas kaikille muillekkin tietokoneille taulukon 3 mukaisesti.

Reititin

Reitittimien R1 ja R2 kohdalla käytetään ns. Router on a Stick metodia eri VLAN-verkkojen väliseen reititykseen. Eri VLAN-verkot eivät pysty liikennöimään keskenään ilman Layer 3 -IP-reititystä. Toisin sanoen tarvitaan joko reititin tai Layer 3 -kytkin.
Router on a Stick toteutetaan sillä tavoin, että kytkimen ja reitittimen välille luodaan yksi trunk-yhteys, joka hoitaa kaikkien VLAN-verkkojen välisen liikenteen. Käytännössä tarvitaan siis vain yksi trunk-kaapeli, ja yksi fyysinen portti molemmissa päissä yhteyttä. Vain yksi fyysinen interface riittää reitittimellä, sillä sille luodaan virtuaalisia ali-interfaceja (subinterface), joista jokaiselle osoitetaan oma tietty VLAN. Tällä tavoin reititin hoitaa eri VLAN-verkkojen välisen reitityksen sisäisesti näiden ali-interfacejen kautta. Liikenne saapuu ja poistuu kuitenkin siitä yhdestä ja samasta reitittimen fyysisestä interfacesta.
Nyt vaan konfiguroidaan reitittimille verkko-osoitteen ohjetaulukon 1 mukaisesti.
Reititin R1:
Serial-interfacet:

R1> enable
R1# configure terminal
R1(config)# interface Serial 0/1/0
R1(config-if)# ip address 150.100.1.1 255.255.255.0
R1(config)# interface Serial 0/1/1
R1(config-if)# ip address 150.100.2.2 255.255.255.0

GigabitEthernet-interfacen ali-interfacet VLAN:eja varten:

R1> enable
R1# configure terminal
R1(config)# interface GigabitEthernet 0/0.10
R1(config-subif)# encapsulation dot1q 10
R1(config-subif)# ip address 150.10.10.1 255.255.255.0
R1(config)# interface GigabitEthernet 0/0.20
R1(config-subif)# encapsulation dot1q 20
R1(config-subif)# ip address 150.10.20.1 255.255.255.0
R1(config)# interface GigabitEthernet 0/0.30
R1(config-subif)# encapsulation dot1q 30
R1(config-subif)# ip address 150.10.30.1 255.255.255.0
R1(config)# interface GigabitEthernet 0/0.99
R1(config-subif)# encapsulation dot1q 99
R1(config-subif)# ip address 150.99.10.1 255.255.255.0

Lopuksi vielä tulee antaa no shutdown komento GigabitEthenet 0/0 -interfacelle. Samalla kaikki ali-interfacet tulee käyttöön.

R1(config)# interface GigabitEthernet 0/0
R1(config-if)# no shutdown

Samalla periaatteella annetaan IP-osoitetiedot R2:lle. Huomaa, että VLAN:it ovat vaan 40, 50 ja 99.
R3:lla ei toteuteta Router on a Stick, joten ali-interfaceja ei tarvita. Tarvitsee ainoastaan konfiguroida IP:t GigabitEthernet- ja Serial-interfaceille.

Kytkimen ylläpito IP

Layer 2-kytkimet eivät liikennöi IP-osoitteiden perusteella. Tämän vuoksi niillä ei myöskään ole itsellään omaa IP-osoitetta. Kuitenkin, jotta kytkimeen saadaan halutessa etäyhteys esimerkiksi SSH:lla, tarvitaan jokin IP, johon otetaan yhteyttä. Tätä tarkoitusta varten kytkimille voidaan määrittää SVI eli Switch Virtual Interface, jolle annetaan IPv4-osoite, jonka avulla laitteeseen saadaan etäyhteys.
Harjoituksen ohjeiden mukaisesti kaikki kytkimet paitsi SW5, ovat VLAN-verkossa 99.
Konfiguroidaan siis seuraavasti SW1:llä:

SW1(config)# interface vlan 99
SW1(config-if)# ip address 150.10.99.100 255.255.255.0
SW1(config-if)# no shutdown
SW1(config-if)# exit
SW1(config)# ip default-gateway 150.10.99.1

Sama muillekkin kytkimille taulukon 2 mukaisesti. SW5:n kohdalla VLAN on sitten taas 1.

VLAN:it ja Trunk-yhteydet

Käytän tässä esimerkkinä kytkintä SW2, sillä se on monipuolisin noista kolmesta.
Aluksi pitää luoda VLAN:it kytkimelle:

SW2(config)# vlan 10,20,30,99

SW2 tarvitsee kolme trunk-yhteyttä: yksi SW1 ja itsenä väliin, yksi SW3 ja itsensä väliin ja yksi reitittimen R1 ja itsensä väliin.
Aloitetaan vaikka siitä Router on a Stick trunk-yhteydestä reitittimen ja kytkimen välillä:

SW2(config)# interface FastEthernet 0/1
SW2(config-if)# switchport mode trunk
SW2(config-if)# switchport trunk allowed vlan 10,20,30,99

Seuraavaksi trunk-yhteydet kytkinten välille.
SW2-SW1:

SW2(config)# interface FastEthernet 0/2
SW2(config-if)# switchport mode trunk
SW2(config-if)# switchport trunk allowed vlan 10,20,99

SW2-SW3:

SW2(config)# interface FastEthernet 0/3
SW2(config-if)# switchport mode trunk
SW2(config-if)# switchport trunk allowed vlan 20,30,99

Lopuksi vielä access-mode kytkimen ja siihen liitettyjen tietokoneiden välille. Samalla määritetään kukin tietokone omaan VLAN-verkkoon:

SW2(config)# interface FastEthernet 0/4
SW2(config-if)# switchport mode access
SW2(config-if)# switchport access vlan 30
SW2(config)# interface FastEthernet 0/5
SW2(config-if)# switchport mode access
SW2(config-if)# switchport access vlan 10

VLAN:it ja trunk-yhteydet on nyt SW2:n kohdalta kunnossa. Samalla periaattella laitetaan kytkimille SW1 ja SW3 access-mode kytkimien ja tietokoneiden välille ja määritellään koneiden VLAN. Pitää tietenkin myös luoda tarvittavat VLAN-verkot kytkimellä.
Trunk-yhteyttä SW2:een ei tarvitse enää näiltä kahdelta kytkimeltä tehdä, sillä se on jo konfiguroitu SW2:n päästä, mikä riittää.
Samalla periaatteella konfiguroidaan myös SW4. Siinä tarvitsee vain luoda access-mode kytkimen ja tietokoneiden välille, sekä trunk-yhteys reitittimen välille Router on a Stick tavoin.
Kytkin SW5 ja siihen kytketyt laitteet ovat default-VLAN:issa 1. Näin ollen siellä ei tarvitse konfiguroida mitään.
Ping kulkee nyt eri VLAN-verkkojen tietokoneiden välillä. Huomaa tosin, että ainoastaan VLAN-verkkojen 10, 20 ja 30 sisällä, sillä reitittimien välille ei ole vielä luotu reititystä. Se tapahtuu harjoituksen seuraavassa osiossa.


TÄTÄ DOKUMENTTIA SAA KOPIOIDA JA MUOKATA GNU GENERAL PUBLIC LICENSE (VERSIO 3 TAI UUDEMPI) MUKAISESTI. HTTP://WWW.GNU.ORG/LICENSES/GPL.HTML
MARKUS PYHÄRANTA
Markus Pyhäranta

RELATED ARTICLES